Completed tutorial 1 and 2

by Mike Linnen 22. June 2006 00:49
Completed tutorial 1 and 2

I just completed the MyTutorial1 and MyTutorial2 tutorials for the Microsoft Robotics Studio.  I used the Lego RSX 2.0 hardware for the tutorials.  I noticed a couple things that stumbled me for a short time.

Problem #1
When you launch the tutorials from the visual studio IDE the services never seem to communicate with the RSX.  I was able to get the service to work using the DSSHOST executable passing in the manifest file.  So I looked at the parameters that the IDE is passing to the DSHOST when you debug and it was using the contract command line option instead of the manifest option.  So I changed it to use the manifest and the service ran fine.

So change the command line debug argument -contract from:

-contract:"http://schemas.tempuri.org/2006/06/mytutorial1.html"
To:
-manifest:"C:\Microsoft Robotics Studio (June 2006)\samples\
MyTutorial1\MyTutorial1.manifest.xml"

And you should be able to launch the service from the IDE

Problem #2
On tutorial number two there is no step to add in the legorcxmotor service to the manifest, so the service never gets started correctly when you run the application from the IDE.  So add the following to the MyTutorial2.manifest.xml file:

      
<SERVICERECORDTYPE>
 <wsap:Contract>
  http://schemas.microsoft.com/robotics/2006/06/legorcxmotor.html
 </wsap:Contract>
</SERVICERECORDTYPE>

Overall I found the two tutorials informative. I at least got my feet wet with using the framework. I might try a few more tutorials before I attempt to write a driver for the BX24.

Comments are closed

About the author

Mike Linnen

Software Engineer specializing in Microsoft Technologies

Month List